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Appendix E 
Installing and configuring the Captioning Manager 

The Mediasite Captioning Manager, a separately sold EX Server add-on, allows users to 
submit and monitor captioning requests through Automatic Sync Technologies® (AST) 
and other captioning services.  When using the AST captioning service, you must use an 
already existing account. Using the credentials of your AST account, you will use the 
Captioning Manager to select a folder for automatic submissions of media files for 
captioning or select individual presentations for captioning.  

This appendix explains how to install and configure the Captioning Manager.  

 
For instructions on using the Captioning Manager, see “Using Mediasite Captioning 
Manager” in the Mediasite Server Guide available on the Customer Assurance Portal at 
www.sonicfoundry.com/support. 

Captioning Manager system requirements 
Captioning Manager must be installed on a machine that meets the following 
requirements:  

� Microsoft Windows XP, Server 2003,  or  Server 2008 
� IIS 5.1 or later 
� Microsoft .NET 3.5 SP1 
� Has a public IP address 

Installing the Captioning Manager 
To install the Captioning Manager:   

1. Double-click CaptioningInstaller.exe and follow the prompts in the Wizard to install 
the software.  

2. On the Mediasite Captioning Manager Location page, click Change to install the 
software in a location other than the default one.  

3. On the Web Site Details page, specify the captioning web service settings:  
Web Site: Choose a web site for the web server from the drop-down list.  

Virtual Directory: The installer creates this virtual directory on the server. This virtual 
directory points to the captioning web service. 
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Callback from AST uses SSL: Clear this check box if you don’t want the AST to use 
SSL to communicate with the EX Server. 

Working Directory: The directory media files will be copied into for new jobs. Click 
Browse to use a location other than the default one. The default directory location is:   
C:\Documents and Settings\All Users\Application Data\Sonic 
Foundry\Captioning Manager Working Directory 

 
Captioning Manager Installation Wizard, Configuration page 

 
4. On the Ready to Install the Mediasite Captioning Manager page, click Next. When the 

configuration is complete, click Finish to exit the Wizard. 

Connecting to the EX Server 
To use the Mediasite Captioning Manager with an EX Server, you must first connect it to 
the EX Server. 

To connect the Captioning Manager to an EX Server: 

1. Click the Captioning Manager 5.1 shortcut on the desktop to launch the Captioning 
Manager.  

2. Click Tools > Options, click the Mediasite Settings tab, click Add New Connection, and 
specify the connection settings: 

3. Enter the site connection properties for the EX Server: 
Name: Enter a name for the site. 
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Mediasite Root URL: The Service Root URL for the EX Server. If you are connecting to 
an EX Server in a high-availability environment, the URL should use the load-
balancer’s IP address or FQDN.  

For example: https://myserver.mynetwork.net/Mediasite51         

Username/Password: The credentials specified for the MediasiteAdmin user during 
installation.  

Test Connection:  Click this button to test the connection to the Mediasite Server. If 
the connection fails, verify the information you entered is correct by comparing it 
against the data in the Configuration Editor and try again.  

4. Click OK to add the connection.  
 

 
Captioning Manager: Mediasite Settings tab 

Now that that the Captioning Manager is installed, you can use it to specify provider 
settings and create and monitor automated captioning jobs. 

 
For instructions, see “Using Mediasite Captioning Manager” in the Mediasite Server Guide 
available on the Customer Assurance Portal at www.sonicfoundry.com/support. 
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Appendix C 
Using Mediasite Captioning Manager 

Use the Mediasite Captioning Manager to submit and monitor captioning requests 
through Automatic Sync Technologies® (AST) and other captioning services.  When using 
the AST captioning service, you must use an already existing account. Using the 
credentials of your AST account, you will use the Captioning Manager to select a folder 
for automatic submissions of media files for captioning or select individual presentations 
for captioning.  

The diagram below shows the workflow between the EX Server and AST when the 
automated captioning options are selected: 

 

 
Automated captioning workflow 

Once jobs are submitted, you can monitor and manage them. Each job has one or more 
items (presentations) to be captioned and you can view status reports for jobs and each 
item within the job. However, you cannot manage individual items within a job. You can 
also use the Captioning Manager to batch download media files for captioning or other 
purposes.  

 
For information on installing and configuring the Captioning Manager, see “Installing and 
Configuring the Captioning Manager” in the Mediasite EX Server Deployment Guide. 
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Specifying the captioning provider details 
Before you can automate captioning using AST, you must specify the provider details. 

1. Click the Captioning Manager 5.3 shortcut on the desktop to launch the Captioning 
Manager.  

2. Click Tools > Options and click the Provider Settings tab and specify the settings that 
will be needed to connect with the automated captioning service: 
Settings Name: Enter a name for the setting.  

Server URL: Enter the URL of the FTP server for the captioning service. For AST, the 
URL is:  
sftp://services.automaticsync.com 

Username: Enter the username required to connect the service. The FTP username is 
provided by your captioning service, not by Sonic Foundry. You must have this 
username before you can use the Captioning Manager with the automated 
captioning service. 

Key Management: When using AST as the captioning provider, you must first 
establish an encryption key to communicate with the service. You can generate a new 
key or you can use an existing key.  

� Key Manager: Click to launch the Key manager dialog. Click Generate Key to 
generate a new key. Click OK to save changes and exit the dialog. 

 
Automated captioning workflow 

� Use .ppk File: Click to navigate to and select the file containing the public key you 
want to use.  

3. Click Test to verify you can connect to the service using the specified settings.  Click 
OK. 
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Captioning Options, Provider settings 

Registering encryption key with AST 
Before you can connect to AST using your encryption key, you must register it on the 
AST website (www.automaticsync.com). You must do this any time you generate a new 
key. 

To register your encryption key: 

1. Go to the AST website, click log in, and enter your account credentials. 
2. Click SSH Keys and select Add Keys. 
3. Go to the Mediasite Captioning Manager, click Tools > Options and click the Provider 

Settings tab. 
4. Click to Key Manager to launch the Key manager dialog. Click Copy Key to Clipboard. 
5. On the AST page, paste the copied key into the Public Key field and add details about 

the key, such as username and machine being used, into the Note for Key field. Click 
Add Key. 



Mediasite Podcasting User Guide  

212 

6. Wait for the status of the key to go from “Pending” to “Ready” in the list. 
7. Once the status has changed, go to the Captioning Manager and click Test to verify 

you can connect to AST. 

Creating new projects 
When you create a new captioning project, you will select one of three options: 
automated captioning for an entire folder, automated captioning for one or more 
presentations, or media download.  

Automate captioning for a folder 
Create this type of project to completely automate the captioning process for any 
presentations published in the selected folder. When this option is selected, Mediasite 
automatically uploads your recorded media files to AST’s captioning service. AST 
captions. These settings only need to be specified once.  

To automate captioning for a folder: 

1. Use the shortcut on the desktop to launch the Captioning Manager. Click Create a 
new captioning project to launch the Captioning Project Wizard. Alternatively, you can 
launch the Wizard by selecting File > New Project. Follow the prompts to create the 
project. 

2. On the Choose Project Type page, select Automated captioning for an entire folder and 
click Next. 

3. On the Project Settings page, specify the project details: 
Project Name: Enter a new name for the project. 

Time Interval: Select how often the service should check the folder for presentations.  

Settings: Select a provider setting from the drop-down list. The captioning provider’s 
FTP Server URL and the username you are using to connect to it are shown.  

View presentations that are offline: Select the check box to also include presentations 
that are not available for on-demand viewing for automated captioning. 

Rush captioning for presentations in this project: Select to use AST’s rush captioning 
service. Contact AST for additional information on this service. 
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Automated captioning for folder option, project settings page 

4. Click Next.  On the following page, folders on the Mediasite Server are shown. 
Navigate to the folder you want and select it. Click Next. 

 

 
Automated captioning for folder option, select folder 

5. On the Project Information page, verify the information is correct. Click Finish to 
accept the changes. The new project is listed in the Mediasite Captioning Manager’s 
project list with a status of Queued.   

Automate captioning for one or more presentations 
When you select this option, you can select presentations from different folders.  

To automate captioning for one or more presentations: 

1. Use the shortcut on the desktop to launch the Captioning Manager. Click Create a 
new captioning project to launch the Captioning Project Wizard. Alternatively, you can 
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launch the Wizard by selecting File > New Project. Follow the prompts to create the 
project. 

2. On the Choose Project Type page, select Automated captioning for one presentation or 
groups of presentations and click Next. 

3. On the Project Settings page, specify the project details: 
Project Name: Enter a new name for the project. 

Settings: Select a provider setting from the drop-down list. The captioning provider’s 
FTP Server URL and the username you are using to connect to it are shown.  

View presentations that are offline: Select the check box to also include presentations 
that are not available for on-demand viewing for automated captioning. 

Rush captioning for presentations in this project: Select to use AST’s rush captioning 
service. Contact AST for additional information on this service. 

 

 
Automated captioning for one or more presentations option, project settings page 

4. Click Next.  On the following page, folders on the Mediasite Server are shown. 
Navigate to the folder you want and select it. Select the checkbox next to each 
presentation you want to include for automated captioning. Click Next. 
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Automated captioning for one or more presentations, select presentations 

5. On the Project Information page, verify the information is correct. Click Finish to 
accept the changes. The new project is listed in the Mediasite Captioning Manager’s 
project list with a status of Queued.   

Download media 
1. Use the shortcut on the desktop to launch the Captioning Manager. Click Create a 

new captioning project to launch the Captioning Project Wizard. Alternatively, you can 
launch the Wizard by selecting File > New Project.  Follow the prompts to create the 
project. 

2. On the Choose Project Type page, select Media Download and click Next. 
3. On the Project Settings page, specify the project details: 

Download Directory: Click Browse to select the directory where you want to 
download media files. The default directory is c:\CaptioningWorkingDir. 

Name downloaded video after: Select one of the radio buttons to name the 
downloaded media file using the presentation’s title or ID number.  

 
Media download option, project settings page 

4. Click Next.  On the following page, folders on the Mediasite Server are shown. 
Navigate to the folder you want and select it. Select the checkbox next to each 
presentation whose media file you want to download.  

5. Click Next to download the media files. Click Finish to exit the Wizard.  
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Managing existing projects 
Once you create a new project, it is immediately placed in the queue. You view the 
project details to monitor its status as well as stop and restart the automated captioning 
process for the project. You can also delete projects. 

View project details 
1. Use the shortcut on the desktop to launch the Captioning Manager.  Click Manage 

existing captioning project to view the list of projects. 
2. Right-click your project in the list, and select Details. For automated captioning for 

folders or multiple presentations, select a presentation to view its details including 
errors.  

3. Click OK to exit the dialog. 
 

 
Media download option, caption project details 

Stop and restart service for a project 
When you automate the captioning process for a folder, the captioning service will poll 
the folder at the interval specified and when new presentations are detected, will upload 
them to the captioning service. In some instances, you may temporarily want to stop the 
automated captioning service for a project and restart it at a later time. 
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To stop and restart service for a project 

1. Use the shortcut on the desktop to launch the Captioning Manager.  Click Manage 
existing captioning project to view the list of projects. 

2. Right-click your project in the list, and select Stop. The automated captioning service 
will no longer poll the folder or process captions for it. 

3. To restart automated captioning for the project, right-click it and select Start. 
 

 
Project list, stop service against project 

Delete a project 
To delete a project you must first stop running the caption service against it. 

1. Use the shortcut on the desktop to launch the Captioning Manager.  Click Manage 
existing captioning project to view the list of projects. 

2. Right-click your project in the list, and select Stop.  
3. Once the status of the project is shown as Canceled, right-click your project in the list, 

and select Delete. 


